What’s Vulnerable › Vulnerabilities

CVE-2011-3192

Description

The byterange filter in the Apache HTTP Server 1.3.x, 2.0.x through 2.0.64, and 2.2.x through 2.2.19 allows remote attackers to cause a denial of service (memory and CPU consumption) via a Range header that expresses multiple overlapping ranges, as exploited in the wild in August 2011, a different vulnerability than CVE-2007-0086.

Affected products

How to fix

Upgrade to a fixed version: Apache HTTP Server 2.0.65, 2.2.20. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2011-3192 or the next vulnerability affects your stack