What’s Vulnerable › Vulnerabilities
CVE-2011-3193
- Severity: critical (CVSS 9.3 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 7.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2012-06-16 · updated 2026-06-16
- Weakness: CWE-787
Description
Heap-based buffer overflow in the Lookup_MarkMarkPos function in the HarfBuzz module (harfbuzz-gpos.c), as used by Qt before 4.7.4 and Pango, allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a crafted font file.
Affected products
- Canonical Ubuntu Linux: 10.04, 11.04
- Gnome Pango: before 1.25.1 — fixed in 1.25.1
- Opensuse: 11.3, 11.4
- Qt: before 4.7.4 — fixed in 4.7.4
- RedHat Enterprise Linux Desktop: 4.0, 5.0, 6.0
- RedHat Enterprise Linux Eus: 6.1
- RedHat Enterprise Linux Server: 4.0, 5.0, 6.0
- RedHat Enterprise Linux Workstation: 4.0, 5.0, 6.0
How to fix
Upgrade to a fixed version: Gnome Pango 1.25.1; Qt 4.7.4. Check the vendor advisory for mitigations.
References
- http://cgit.freedesktop.org/harfbuzz.old/commit/?id=81c8ef785b079980ad5b46be4fe7c7bf156dbf65
- http://cgit.freedesktop.org/harfbuzz/commit/src/harfbuzz-gpos.c?id=da2c52abcd75d46929b34cad55c4fb2c8892bc08
- http://git.gnome.org/browse/pango/commit/pango/opentype/harfbuzz-gpos.c?id=a7a715480db66148b1f487528887508a7991dcd0
- http://lists.opensuse.org/opensuse-updates/2011-10/msg00007.html
- http://lists.opensuse.org/opensuse-updates/2011-10/msg00008.html
- http://rhn.redhat.com/errata/RHSA-2011-1323.html
- http://rhn.redhat.com/errata/RHSA-2011-1324.html
- http://rhn.redhat.com/errata/RHSA-2011-1325.html
- http://rhn.redhat.com/errata/RHSA-2011-1326.html
- http://rhn.redhat.com/errata/RHSA-2011-1327.html
- http://rhn.redhat.com/errata/RHSA-2011-1328.html
- http://secunia.com/advisories/41537
Get alerted when CVE-2011-3193 or the next vulnerability affects your stack