What’s Vulnerable › Vulnerabilities
CVE-2011-3596
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 11.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-11-26 · updated 2026-06-16
- Weakness: CWE-617
Description
Polipo before 1.0.4.1 suffers from a DoD vulnerability via specially-crafted HTTP POST / PUT request.
Affected products
- Debian Linux: 8.0, 9.0, 10.0
- Polipo Project Polipo: before 1.0.4.1 — fixed in 1.0.4.1
How to fix
Upgrade to a fixed version: Polipo Project Polipo 1.0.4.1. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/security/cve/cve-2011-3596
- https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=644289
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2011-3596
- https://security-tracker.debian.org/tracker/CVE-2011-3596
- https://access.redhat.com/security/cve/cve-2011-3596
- https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=644289
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2011-3596
- https://security-tracker.debian.org/tracker/CVE-2011-3596
Get alerted when CVE-2011-3596 or the next vulnerability affects your stack