What’s Vulnerable › Vulnerabilities
CVE-2011-3656
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-06-02 · updated 2026-06-16
- Weakness: CWE-79
Description
Cross-site scripting (XSS) vulnerability in Mozilla Firefox before 3.6.24 and 4.x through 7 allows remote attackers to inject arbitrary web script or HTML via vectors involving HTTP 0.9 errors, non-default ports, and content-sniffing.
Affected products
- Mozilla Firefox: before 3.6.24; from 4.0 through 7.0 — fixed in 3.6.24
How to fix
Upgrade to a fixed version: Mozilla Firefox 3.6.24. Check the vendor advisory for mitigations.
References
- https://bugzilla.mozilla.org/show_bug.cgi?id=667907
- https://bugzilla.mozilla.org/show_bug.cgi?id=667907
Get alerted when CVE-2011-3656 or the next vulnerability affects your stack