What’s Vulnerable › Vulnerabilities
CVE-2011-3919
- Severity: high (CVSS 7.5 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2012-01-07 · updated 2026-06-16
- Weakness: CWE-787
Description
Heap-based buffer overflow in libxml2, as used in Google Chrome before 16.0.912.75, allows remote attackers to cause a denial of service or possibly have unspecified other impact via unknown vectors.
Affected products
- Apple Iphone Os: before 6.0 — fixed in 6.0
- macOS: before 10.7.4 — fixed in 10.7.4
- Debian Linux: 5.0, 6.0, 7.0
- Google Chrome: before 16.0.912.75 — fixed in 16.0.912.75
- RedHat Enterprise Linux Desktop: 6.0
- RedHat Enterprise Linux Server: 6.0
- RedHat Enterprise Linux Server Eus: 6.3
- RedHat Enterprise Linux Workstation: 6.0
- SUSE Linux Enterprise Server: 10-sp4
How to fix
Upgrade to a fixed version: Apple Iphone Os 6.0; macOS 10.7.4; Google Chrome 16.0.912.75. Check the vendor advisory for mitigations.
References
- http://code.google.com/p/chromium/issues/detail?id=107128
- http://googlechromereleases.blogspot.com/2012/01/stable-channel-update.html
- http://lists.apple.com/archives/security-announce/2012/May/msg00001.html
- http://lists.apple.com/archives/security-announce/2012/Sep/msg00003.html
- http://lists.opensuse.org/opensuse-security-announce/2013-11/msg00002.html
- http://rhn.redhat.com/errata/RHSA-2013-0217.html
- http://secunia.com/advisories/47449
- http://secunia.com/advisories/55568
- http://support.apple.com/kb/HT5281
- http://support.apple.com/kb/HT5503
- http://www.debian.org/security/2012/dsa-2394
- http://www.mandriva.com/security/advisories?name=MDVSA-2012:005
Get alerted when CVE-2011-3919 or the next vulnerability affects your stack