What’s Vulnerable › Vulnerabilities
CVE-2011-3923
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 89.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-11-01 · updated 2026-06-16
- Weakness: CWE-732
Description
Apache Struts before 2.3.1.2 allows remote attackers to bypass security protections in the ParameterInterceptor class and execute arbitrary commands.
Affected products
- Apache Struts: from 2.0.0 before 2.3.1.2 — fixed in 2.3.1.2
- Red Hat JBoss Enterprise Web Server: 1.0.0
How to fix
Upgrade to a fixed version: Apache Struts 2.3.1.2. Check the vendor advisory for mitigations.
References
- http://seclists.org/fulldisclosure/2014/Jul/38
- http://www.exploit-db.com/exploits/24874
- http://www.securityfocus.com/bid/51628
- http://www.securitytracker.com/id?1026575
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2011-3923
- https://exchange.xforce.ibmcloud.com/vulnerabilities/72585
- https://security-tracker.debian.org/tracker/CVE-2011-3923
- http://seclists.org/fulldisclosure/2014/Jul/38
- http://www.exploit-db.com/exploits/24874
- http://www.securityfocus.com/bid/51628
- http://www.securitytracker.com/id?1026575
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2011-3923
Get alerted when CVE-2011-3923 or the next vulnerability affects your stack