What’s Vulnerable › Vulnerabilities

CVE-2011-4107

Description

The simplexml_load_string function in the XML import plug-in (libraries/import/xml.php) in phpMyAdmin 3.4.x before 3.4.7.1 and 3.3.x before 3.3.10.5 allows remote authenticated users to read arbitrary files via XML data containing external entity references, aka an XML external entity (XXE) injection attack.

Affected products

How to fix

Upgrade to a fixed version: phpMyAdmin 3.3.10.5, 3.4.7.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2011-4107 or the next vulnerability affects your stack