What’s Vulnerable › Vulnerabilities
CVE-2011-4120
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-11-26 · updated 2026-06-16
- Weakness: CWE-20
Description
Yubico PAM Module before 2.10 performed user authentication when 'use_first_pass' PAM configuration option was not used and the module was configured as 'sufficient' in the PAM configuration. A remote attacker could use this flaw to circumvent common authentication process and obtain access to the account in question by providing a NULL value (pressing Ctrl-D keyboard sequence) as the password string.
Affected products
- Debian Linux: 8.0, 9.0, 10.0
- Yubico Pam Module: before 2.10 — fixed in 2.10
How to fix
Upgrade to a fixed version: Yubico Pam Module 2.10. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/security/cve/cve-2011-4120
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2011-4120
- https://security-tracker.debian.org/tracker/CVE-2011-4120
- https://www.openwall.com/lists/oss-security/2011/11/07/6
- https://access.redhat.com/security/cve/cve-2011-4120
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2011-4120
- https://security-tracker.debian.org/tracker/CVE-2011-4120
- https://www.openwall.com/lists/oss-security/2011/11/07/6
Get alerted when CVE-2011-4120 or the next vulnerability affects your stack