What’s Vulnerable › Vulnerabilities
CVE-2011-4213
- Severity: high (CVSS 7.2 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2011-10-30 · updated 2026-06-16
- Weakness: CWE-264
Description
The sandbox environment in the Google App Engine Python SDK before 1.5.4 does not properly prevent use of the os module, which allows local users to bypass intended access restrictions and execute arbitrary commands via a file_blob_storage.os reference within the code parameter to _ah/admin/interactive/execute, a different vulnerability than CVE-2011-1364.
Affected products
- Google App Engine Python Sdk: before 1.5.4 — fixed in 1.5.4
How to fix
Upgrade to a fixed version: Google App Engine Python Sdk 1.5.4. Check the vendor advisory for mitigations.
References
- http://blog.watchfire.com/files/googleappenginesdk.pdf
- http://code.google.com/p/googleappengine/wiki/SdkReleaseNotes
- https://exchange.xforce.ibmcloud.com/vulnerabilities/71062
- http://blog.watchfire.com/files/googleappenginesdk.pdf
- http://code.google.com/p/googleappengine/wiki/SdkReleaseNotes
- https://exchange.xforce.ibmcloud.com/vulnerabilities/71062
Get alerted when CVE-2011-4213 or the next vulnerability affects your stack