What’s Vulnerable › Vulnerabilities
CVE-2011-4315
- Severity: medium (CVSS 6.8 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 6.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2011-12-08 · updated 2026-06-16
- Weakness: CWE-787
Description
Heap-based buffer overflow in compression-pointer processing in core/ngx_resolver.c in nginx before 1.0.10 allows remote resolvers to cause a denial of service (daemon crash) or possibly have unspecified other impact via a long response.
Affected products
- nginx: from 0.6.18 before 1.0.10; from 1.1.0 through 1.1.7 — fixed in 1.0.10
- Fedoraproject Fedora: 16
- SUSE Studio: 1.2
- SUSE Studio onsite: 1.2
- SUSE Webyast: 1.2
How to fix
Upgrade to a fixed version: nginx 1.0.10. Check the vendor advisory for mitigations.
References
- http://lists.fedoraproject.org/pipermail/package-announce/2011-December/070569.html
- http://lists.opensuse.org/opensuse-security-announce/2011-12/msg00005.html
- http://openwall.com/lists/oss-security/2011/11/17/10
- http://openwall.com/lists/oss-security/2011/11/17/8
- http://secunia.com/advisories/47097
- http://secunia.com/advisories/48577
- http://security.gentoo.org/glsa/glsa-201203-22.xml
- http://trac.nginx.org/nginx/changeset/4268/nginx
- http://www.nginx.org/en/CHANGES-1.0
- http://www.securityfocus.com/bid/50710
- http://lists.fedoraproject.org/pipermail/package-announce/2011-December/070569.html
- http://lists.opensuse.org/opensuse-security-announce/2011-12/msg00005.html
Get alerted when CVE-2011-4315 or the next vulnerability affects your stack