What’s Vulnerable › Vulnerabilities
CVE-2011-4361
- Severity: medium (CVSS 5.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2012-01-08 · updated 2026-06-16
- Weakness: CWE-276
Description
MediaWiki before 1.17.1 does not check for read permission before handling action=ajax requests, which allows remote attackers to obtain sensitive information by (1) leveraging the SpecialUpload::ajaxGetExistsWarning function, or by (2) leveraging an extension, as demonstrated by the CategoryTree, ExtTab, and InlineEditor extensions.
Affected products
- Debian Linux: 5.0, 6.0
- Wikimedia Foundation MediaWiki: before 1.17.1 — fixed in 1.17.1
How to fix
Upgrade to a fixed version: Wikimedia Foundation MediaWiki 1.17.1. Check the vendor advisory for mitigations.
References
- http://lists.wikimedia.org/pipermail/mediawiki-announce/2011-November/000104.html
- http://openwall.com/lists/oss-security/2011/11/29/12
- http://openwall.com/lists/oss-security/2011/11/29/6
- http://www.debian.org/security/2011/dsa-2366
- https://bugzilla.redhat.com/show_bug.cgi?id=758171
- https://bugzilla.wikimedia.org/show_bug.cgi?id=32616
- http://lists.wikimedia.org/pipermail/mediawiki-announce/2011-November/000104.html
- http://openwall.com/lists/oss-security/2011/11/29/12
- http://openwall.com/lists/oss-security/2011/11/29/6
- http://www.debian.org/security/2011/dsa-2366
- https://bugzilla.redhat.com/show_bug.cgi?id=758171
- https://bugzilla.wikimedia.org/show_bug.cgi?id=32616
Get alerted when CVE-2011-4361 or the next vulnerability affects your stack