What’s Vulnerable › Vulnerabilities
CVE-2011-4566
- Severity: medium (CVSS 6.4 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 6.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2011-11-29 · updated 2026-06-16
- Weakness: CWE-189
Description
Integer overflow in the exif_process_IFD_TAG function in exif.c in the exif extension in PHP 5.4.0beta2 on 32-bit platforms allows remote attackers to read the contents of arbitrary memory locations or cause a denial of service via a crafted offset_val value in an EXIF header in a JPEG file, a different vulnerability than CVE-2011-0708.
Affected products
- Canonical Ubuntu Linux: 8.04, 10.04, 10.10, 11.04, 11.10
- Debian Linux: 5.0, 6.0, 7.0
- PHP: from 5.3.0 before 5.3.9; 5.4.0-beta2 — fixed in 5.3.9
How to fix
Upgrade to a fixed version: PHP 5.3.9. Check the vendor advisory for mitigations.
References
- http://lists.apple.com/archives/security-announce/2012/May/msg00001.html
- http://lists.opensuse.org/opensuse-security-announce/2012-03/msg00016.html
- http://rhn.redhat.com/errata/RHSA-2012-0071.html
- http://secunia.com/advisories/47253
- http://secunia.com/advisories/48668
- http://support.apple.com/kb/HT5281
- http://www.debian.org/security/2012/dsa-2399
- http://www.mandriva.com/security/advisories?name=MDVSA-2011:197
- http://www.redhat.com/support/errata/RHSA-2012-0019.html
- http://www.securityfocus.com/bid/50907
- https://bugs.php.net/bug.php?id=60150
- https://exchange.xforce.ibmcloud.com/vulnerabilities/71612
Get alerted when CVE-2011-4566 or the next vulnerability affects your stack