What’s Vulnerable › Vulnerabilities
CVE-2011-4625
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-11-06 · updated 2026-06-16
- Weakness: CWE-755
Description
simplesamlphp before 1.6.3 (squeeze) and before 1.8.2 (sid) incorrectly handles XML encryption which could allow remote attackers to decrypt or forge messages.
Affected products
- Debian Linux: 8.0, 9.0, 10.0
- simplesamlphp: from 1.6.0 before 1.6.3; from 1.8.0 before 1.8.2 — fixed in 1.6.3, 1.8.2
How to fix
Upgrade to a fixed version: simplesamlphp 1.6.3, 1.8.2. Check the vendor advisory for mitigations.
References
- https://security-tracker.debian.org/tracker/CVE-2011-4625
- https://www.mageni.net/1.3.6.1.4.1.25623.1.0.70545
- https://security-tracker.debian.org/tracker/CVE-2011-4625
- https://www.mageni.net/1.3.6.1.4.1.25623.1.0.70545
Get alerted when CVE-2011-4625 or the next vulnerability affects your stack