What’s Vulnerable › Vulnerabilities
CVE-2011-4838
- Severity: medium (CVSS 5.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2011-12-30 · updated 2026-06-16
- Weakness: CWE-400
Description
JRuby before 1.6.5.1 computes hash values without restricting the ability to trigger hash collisions predictably, which allows context-dependent attackers to cause a denial of service (CPU consumption) via crafted input to an application that maintains a hash table.
Affected products
- Jruby: before 1.6.5.1 — fixed in 1.6.5.1
How to fix
Upgrade to a fixed version: Jruby 1.6.5.1. Check the vendor advisory for mitigations.
References
- http://archives.neohapsis.com/archives/bugtraq/2011-12/0181.html
- http://jruby.org/2011/12/27/jruby-1-6-5-1.html
- http://rhn.redhat.com/errata/RHSA-2012-1232.html
- http://secunia.com/advisories/47407
- http://secunia.com/advisories/50084
- http://security.gentoo.org/glsa/glsa-201207-06.xml
- http://www.kb.cert.org/vuls/id/903934
- http://www.nruns.com/_downloads/advisory28122011.pdf
- http://www.ocert.org/advisories/ocert-2011-003.html
- https://exchange.xforce.ibmcloud.com/vulnerabilities/72019
- http://archives.neohapsis.com/archives/bugtraq/2011-12/0181.html
- http://jruby.org/2011/12/27/jruby-1-6-5-1.html
Get alerted when CVE-2011-4838 or the next vulnerability affects your stack