What’s Vulnerable › Vulnerabilities

CVE-2011-4862

Description

Buffer overflow in libtelnet/encrypt.c in telnetd in FreeBSD 7.3 through 9.0, MIT Kerberos Version 5 Applications (aka krb5-appl) 1.0.2 and earlier, Heimdal 1.5.1 and earlier, GNU inetutils, and possibly other products allows remote attackers to execute arbitrary code via a long encryption key, as exploited in the wild in December 2011.

Affected products

How to fix

Upgrade to a fixed version: GNU inetutils 1.9. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2011-4862 or the next vulnerability affects your stack