What’s Vulnerable › Vulnerabilities

CVE-2011-4924

Description

Cross-site scripting (XSS) vulnerability in Zope 2.8.x before 2.8.12, 2.9.x before 2.9.12, 2.10.x before 2.10.11, 2.11.x before 2.11.6, and 2.12.x before 2.12.3, 3.1.1 through 3.4.1. allows remote attackers to inject arbitrary web script or HTML via vectors related to the way error messages perform sanitization. NOTE: this issue exists because of an incomplete fix for CVE-2010-1104

Affected products

How to fix

Upgrade to a fixed version: zopefoundation Zope 2.10.11, 2.11.6, 2.12.3, 2.8.12. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2011-4924 or the next vulnerability affects your stack