What’s Vulnerable › Vulnerabilities
CVE-2011-5057
- Severity: medium (CVSS 5.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 27.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2012-01-08 · updated 2026-06-16
- Weakness: CWE-264
Description
Apache Struts 2.3.1.2 and earlier, 2.3.19-2.3.23, provides interfaces that do not properly restrict access to collections such as the session and request collections, which might allow remote attackers to modify run-time data values via a crafted parameter to an application that implements an affected interface, as demonstrated by the SessionAware, RequestAware, ApplicationAware, ServletRequestAware, ServletResponseAware, and ParameterAware interfaces. NOTE: the vendor disputes the significance of this report because of an "easy work-around in existing apps by configuring the interceptor."
Affected products
- Apache Struts: from 2.0.0 before 2.3.3 — fixed in 2.3.3
How to fix
Upgrade to a fixed version: Apache Struts 2.3.3. Check the vendor advisory for mitigations.
References
- http://codesecure.blogspot.com/2011/12/struts-2-session-tampering-via.html
- http://secunia.com/advisories/47109
- https://issues.apache.org/jira/browse/WW-2264
- https://issues.apache.org/jira/browse/WW-3631
- http://codesecure.blogspot.com/2011/12/struts-2-session-tampering-via.html
- http://secunia.com/advisories/47109
- https://issues.apache.org/jira/browse/WW-2264
- https://issues.apache.org/jira/browse/WW-3631
Get alerted when CVE-2011-5057 or the next vulnerability affects your stack