What’s Vulnerable › Vulnerabilities
CVE-2012-0049
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-11-07 · updated 2026-06-16
- Weakness: CWE-400
Description
OpenTTD before 1.1.5 contains a Denial of Service (slow read attack) that prevents users from joining the server.
Affected products
- Debian Linux: 6.0, 8.0, 9.0, 10.0
- Fedoraproject Fedora: 15, 16
- openttd: before 1.1.5 — fixed in 1.1.5
How to fix
Upgrade to a fixed version: openttd 1.1.5. Check the vendor advisory for mitigations.
References
- http://security.openttd.org/en/CVE-2012-0049
- http://www.debian.org/security/2012/dsa-2524
- http://www.openwall.com/lists/oss-security/2012/01/13/9
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2012-0049
- https://security-tracker.debian.org/tracker/CVE-2012-0049
- http://security.openttd.org/en/CVE-2012-0049
- http://www.debian.org/security/2012/dsa-2524
- http://www.openwall.com/lists/oss-security/2012/01/13/9
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2012-0049
- https://security-tracker.debian.org/tracker/CVE-2012-0049
Get alerted when CVE-2012-0049 or the next vulnerability affects your stack