What’s Vulnerable › Vulnerabilities

CVE-2012-0053

Description

protocol.c in the Apache HTTP Server 2.2.x through 2.2.21 does not properly restrict header information during construction of Bad Request (aka 400) error documents, which allows remote attackers to obtain the values of HTTPOnly cookies via vectors involving a (1) long or (2) malformed header in conjunction with crafted web script.

Affected products

How to fix

Upgrade to a fixed version: Apache HTTP Server 2.0.65, 2.2.22. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2012-0053 or the next vulnerability affects your stack