What’s Vulnerable › Vulnerabilities
CVE-2012-0260
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2012-06-05 · updated 2026-06-16
- Weakness: CWE-400
Description
The JPEGWarningHandler function in coders/jpeg.c in ImageMagick before 6.7.6-3 allows remote attackers to cause a denial of service (memory consumption) via a JPEG image with a crafted sequence of restart markers.
Affected products
- Canonical Ubuntu Linux: 12.04, 12.10, 13.10
- Debian Linux: 6.0
- ImageMagick: before 6.7.6-3 — fixed in 6.7.6-3
- Opensuse: 11.4, 12.1
- RedHat Enterprise Linux Aus: 6.2
- RedHat Enterprise Linux Desktop: 5.0, 6.0
- RedHat Enterprise Linux Eus: 6.2
- RedHat Enterprise Linux Server: 5.0, 6.0
- RedHat Enterprise Linux Server Eus: 6.2
- RedHat Enterprise Linux Workstation: 5.0, 6.0
- RedHat Storage: 2.0
How to fix
Upgrade to a fixed version: ImageMagick 6.7.6-3. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-updates/2012-06/msg00001.html
- http://rhn.redhat.com/errata/RHSA-2012-0544.html
- http://rhn.redhat.com/errata/RHSA-2012-0545.html
- http://secunia.com/advisories/48974
- http://secunia.com/advisories/49063
- http://secunia.com/advisories/49068
- http://secunia.com/advisories/49317
- http://secunia.com/advisories/55035
- http://secunia.com/advisories/57224
- http://www.cert.fi/en/reports/2012/vulnerability635606.html
- http://www.debian.org/security/2012/dsa-2462
- http://www.imagemagick.org/discourse-server/viewtopic.php?f=4&t=20629
Get alerted when CVE-2012-0260 or the next vulnerability affects your stack