What’s Vulnerable › Vulnerabilities
CVE-2012-0393
- Severity: medium (CVSS 6.4 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 36.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2012-01-08 · updated 2026-06-16
- Weakness: CWE-264
Description
The ParameterInterceptor component in Apache Struts before 2.3.1.1 does not prevent access to public constructors, which allows remote attackers to create or overwrite arbitrary files via a crafted parameter that triggers the creation of a Java object.
Affected products
- Apache Struts: from 2.1.0 before 2.3.1.1 — fixed in 2.3.1.1
How to fix
Upgrade to a fixed version: Apache Struts 2.3.1.1. Check the vendor advisory for mitigations.
References
- http://archives.neohapsis.com/archives/bugtraq/2012-01/0031.html
- http://secunia.com/advisories/47393
- http://struts.apache.org/2.x/docs/s2-008.html
- http://struts.apache.org/2.x/docs/version-notes-2311.html
- http://www.exploit-db.com/exploits/18329
- https://www.sec-consult.com/files/20120104-0_Apache_Struts2_Multiple_Critical_Vulnerabilities.txt
- http://archives.neohapsis.com/archives/bugtraq/2012-01/0031.html
- http://secunia.com/advisories/47393
- http://struts.apache.org/2.x/docs/s2-008.html
- http://struts.apache.org/2.x/docs/version-notes-2311.html
- http://www.exploit-db.com/exploits/18329
- https://www.sec-consult.com/files/20120104-0_Apache_Struts2_Multiple_Critical_Vulnerabilities.txt
Get alerted when CVE-2012-0393 or the next vulnerability affects your stack