What’s Vulnerable › Vulnerabilities
CVE-2012-0442
- Severity: critical (CVSS 9.3 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2012-02-01 · updated 2026-06-16
Description
Multiple unspecified vulnerabilities in the browser engine in Mozilla Firefox before 3.6.26 and 4.x through 9.0, Thunderbird before 3.1.18 and 5.0 through 9.0, and SeaMonkey before 2.7 allow remote attackers to cause a denial of service (memory corruption and application crash) or possibly execute arbitrary code via unknown vectors.
Affected products
- Debian Linux: 5.0, 6.0
- Mozilla Firefox: before 3.6.26; from 4.0 before 10.0 — fixed in 10.0, 3.6.26
- Mozilla Seamonkey: before 2.7 — fixed in 2.7
- Mozilla Thunderbird: before 3.1.18; from 5.0 before 10.0 — fixed in 10.0, 3.1.18
- Opensuse: 11.4
- SUSE Linux Enterprise Server 15 SP1: 10-sp4, 11-sp1
- SUSE Linux Enterprise Server: 10-sp4, 11-sp1
- SUSE Linux Enterprise Software Development Kit: 10-sp4, 11-sp1
How to fix
Upgrade to a fixed version: Mozilla Firefox 10.0, 3.6.26; Mozilla Seamonkey 2.7; Mozilla Thunderbird 10.0, 3.1.18. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2012-02/msg00003.html
- http://lists.opensuse.org/opensuse-security-announce/2012-02/msg00007.html
- http://lists.opensuse.org/opensuse-security-announce/2012-02/msg00011.html
- http://www.debian.org/security/2012/dsa-2400
- http://www.debian.org/security/2012/dsa-2402
- http://www.debian.org/security/2012/dsa-2406
- http://www.mandriva.com/security/advisories?name=MDVSA-2012:013
- http://www.mozilla.org/security/announce/2012/mfsa2012-01.html
- https://bugzilla.mozilla.org/show_bug.cgi?id=693399
- https://bugzilla.mozilla.org/show_bug.cgi?id=705347
- https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A14678
- http://lists.opensuse.org/opensuse-security-announce/2012-02/msg00003.html
Get alerted when CVE-2012-0442 or the next vulnerability affects your stack