What’s Vulnerable › Vulnerabilities
CVE-2012-0578
- Severity: medium (CVSS 4.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2013-01-17 · updated 2026-06-16
Description
Unspecified vulnerability in the Server component in Oracle MySQL 5.5.28 and earlier allows remote authenticated users to affect availability via unknown vectors related to Server Optimizer.
Affected products
- Canonical Ubuntu Linux: 10.04, 11.10, 12.04, 12.10
- MariaDB: from 5.5.0 before 5.5.29; 10.0.0 — fixed in 5.5.29
- MySQL Server: from 5.1.0 through 5.1.66; from 5.5.0 through 5.5.28
How to fix
Upgrade to a fixed version: MariaDB 5.5.29. Check the vendor advisory for mitigations.
References
- http://secunia.com/advisories/53372
- http://security.gentoo.org/glsa/glsa-201308-06.xml
- http://www.mandriva.com/security/advisories?name=MDVSA-2013:150
- http://www.oracle.com/technetwork/topics/security/cpujan2013-1515902.html
- http://www.ubuntu.com/usn/USN-1703-1
- https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A16947
- http://secunia.com/advisories/53372
- http://security.gentoo.org/glsa/glsa-201308-06.xml
- http://www.mandriva.com/security/advisories?name=MDVSA-2013:150
- http://www.oracle.com/technetwork/topics/security/cpujan2013-1515902.html
- http://www.ubuntu.com/usn/USN-1703-1
- https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A16947
Get alerted when CVE-2012-0578 or the next vulnerability affects your stack