What’s Vulnerable › Vulnerabilities
CVE-2012-0754: Adobe Flash Player Memory Corruption Vulnerability
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2022-06-08
- EPSS: 91.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2012-02-16 · updated 2026-06-16
- Weakness: CWE-787
Description
Adobe Flash Player before 10.3.183.15 and 11.x before 11.1.102.62 on Windows, Mac OS X, Linux, and Solaris; before 11.1.111.6 on Android 2.x and 3.x; and before 11.1.115.6 on Android 4.x allows attackers to execute arbitrary code or cause a denial of service (memory corruption) via unspecified vectors.
Affected products
- Adobe Flash Player 24.0.0.186 and earlier.: before 10.3.183.15; from 11.0 before 11.1.102.62; before 11.1.111.6; before 11.1.115.6 — fixed in 10.3.183.15, 11.1.102.62, 11.1.111.6, 11.1.115.6
How to fix
Upgrade to a fixed version: Adobe Flash Player 24.0.0.186 and earlier. 10.3.183.15, 11.1.102.62, 11.1.111.6, 11.1.115.6. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2012-02/msg00014.html
- http://rhn.redhat.com/errata/RHSA-2012-0144.html
- http://secunia.com/advisories/48265
- http://secunia.com/advisories/48819
- http://security.gentoo.org/glsa/glsa-201204-07.xml
- http://www.adobe.com/support/security/bulletins/apsb12-03.html
- https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A15030
- https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A15973
- http://lists.opensuse.org/opensuse-security-announce/2012-02/msg00014.html
- http://rhn.redhat.com/errata/RHSA-2012-0144.html
- http://secunia.com/advisories/48265
- http://secunia.com/advisories/48819
Get alerted when CVE-2012-0754 or the next vulnerability affects your stack