What’s Vulnerable › Vulnerabilities
CVE-2012-0777
- Severity: medium (CVSS 6.8 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 7.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2012-04-10 · updated 2026-06-16
- Weakness: CWE-119
Description
The JavaScript API in Adobe Reader and Acrobat 9.x before 9.5.1 and 10.x before 10.1.3 on Mac OS X and Linux allows attackers to execute arbitrary code or cause a denial of service (memory corruption) via unspecified vectors.
Affected products
- Adobe Acrobat for Edge: from 9.0 before 9.5.1; from 10.0 before 10.1.3 — fixed in 10.1.3, 9.5.1
- Adobe Acrobat Reader: from 9.0 before 9.5.1; from 10.0 before 10.1.3 — fixed in 10.1.3, 9.5.1
How to fix
Upgrade to a fixed version: Adobe Acrobat for Edge 10.1.3, 9.5.1; Adobe Acrobat Reader 10.1.3, 9.5.1. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2012-04/msg00013.html
- http://lists.opensuse.org/opensuse-security-announce/2012-04/msg00016.html
- http://lists.opensuse.org/opensuse-security-announce/2012-04/msg00017.html
- http://rhn.redhat.com/errata/RHSA-2012-0469.html
- http://secunia.com/advisories/48756
- http://secunia.com/advisories/48846
- http://www.adobe.com/support/security/bulletins/apsb12-08.html
- http://www.securityfocus.com/bid/52950
- http://www.securitytracker.com/id?1026908
- http://www.us-cert.gov/cas/techalerts/TA12-101B.html
- https://exchange.xforce.ibmcloud.com/vulnerabilities/74735
- http://lists.opensuse.org/opensuse-security-announce/2012-04/msg00013.html
Get alerted when CVE-2012-0777 or the next vulnerability affects your stack