What’s Vulnerable › Vulnerabilities
CVE-2012-0828
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-02-21 · updated 2026-06-16
- Weakness: CWE-787
Description
Heap-based buffer overflow in Xchat-WDK before 1499-4 (2012-01-18) xchat 2.8.6 on Maemo architecture could allow remote attackers to cause a denial of service (xchat client crash) or execute arbitrary code via a UTF-8 line from server containing characters outside of the Basic Multilingual Plane (BMP).
Affected products
- GNOME Gtk: 2.10.4, 2.14.7, 2.18.9, 2.24.7
- xchat: before 2.8.6 — fixed in 2.8.6
- Xchat-Wdk: before 1499-4 — fixed in 1499-4
How to fix
Upgrade to a fixed version: xchat 2.8.6; Xchat-Wdk 1499-4. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2012/02/01/9
- https://access.redhat.com/security/cve/cve-2012-0828
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2012-0828
- https://security-tracker.debian.org/tracker/CVE-2012-0828
- http://www.openwall.com/lists/oss-security/2012/02/01/9
- https://access.redhat.com/security/cve/cve-2012-0828
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2012-0828
- https://security-tracker.debian.org/tracker/CVE-2012-0828
Get alerted when CVE-2012-0828 or the next vulnerability affects your stack