What’s Vulnerable › Vulnerabilities
CVE-2012-0911
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 63.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2012-07-12 · updated 2026-06-16
- Weakness: CWE-502
Description
TikiWiki CMS/Groupware before 6.7 LTS and before 8.4 allows remote attackers to execute arbitrary PHP code via a crafted serialized object in the (1) cookieName to lib/banners/bannerlib.php; (2) printpages or (3) printstructures parameter to (a) tiki-print_multi_pages.php or (b) tiki-print_pages.php; or (4) sendpages, (5) sendstructures, or (6) sendarticles parameter to tiki-send_objects.php, which is not properly handled when processed by the unserialize function.
Affected products
- Tiki: before 6.7; before 8.4 — fixed in 6.7, 8.4
How to fix
Upgrade to a fixed version: Tiki 6.7, 8.4. Check the vendor advisory for mitigations.
References
- http://archives.neohapsis.com/archives/bugtraq/2012-07/0020.html
- http://dev.tiki.org/item4109
- http://info.tiki.org/article190-Tiki-Wiki-CMS-Groupware-Updates-Tiki-6-7-LTS
- http://info.tiki.org/article191-Tiki-Releases-8-4
- http://osvdb.org/83534
- http://www.exploit-db.com/exploits/19573
- http://www.exploit-db.com/exploits/19630
- http://www.securityfocus.com/bid/54298
- https://exchange.xforce.ibmcloud.com/vulnerabilities/76758
- http://archives.neohapsis.com/archives/bugtraq/2012-07/0020.html
- http://dev.tiki.org/item4109
- http://info.tiki.org/article190-Tiki-Wiki-CMS-Groupware-Updates-Tiki-6-7-LTS
Get alerted when CVE-2012-0911 or the next vulnerability affects your stack