What’s Vulnerable › Vulnerabilities
CVE-2012-0941
- Severity: medium (CVSS 6.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-02-08 · updated 2026-06-16
- Weakness: CWE-79
Description
Multiple cross-site scripting (XSS) vulnerabilities in Fortinet FortiGate UTM WAF appliances with FortiOS 4.3.x before 4.3.6 allow remote attackers to inject arbitrary web script or HTML via vectors involving the (1) Endpoint Monitor, (2) Dialup List, or (3) Log&Report Display modules, or the fields_sorted_opt parameter to (4) user/auth/list or (5) endpointcompliance/app_detect/predefined_sig_list.
Affected products
- Fortinet FortiOS (FortiGate): from 4.3.0 before 4.3.6 — fixed in 4.3.6
How to fix
Upgrade to a fixed version: Fortinet FortiOS (FortiGate) 4.3.6. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.org/files/109168/VL-144.txt
- http://www.securityfocus.com/bid/51708
- https://exchange.xforce.ibmcloud.com/vulnerabilities/72761
- https://fortiguard.com/psirt/FG-IR-012-001
- https://securitytracker.com/id/1026594
- https://www.vulnerability-lab.com/get_content.php?id=144
- http://packetstormsecurity.org/files/109168/VL-144.txt
- http://www.securityfocus.com/bid/51708
- https://exchange.xforce.ibmcloud.com/vulnerabilities/72761
- https://fortiguard.com/psirt/FG-IR-012-001
- https://securitytracker.com/id/1026594
- https://www.vulnerability-lab.com/get_content.php?id=144
Get alerted when CVE-2012-0941 or the next vulnerability affects your stack