What’s Vulnerable › Vulnerabilities
CVE-2012-10004: backdrop-contrib Basic Cart basic_cart.cart.inc basic_cart_checkout_form_submit cross site scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-01-11 · updated 2026-06-16
- Weakness: CWE-79
Description
A vulnerability was found in backdrop-contrib Basic Cart on Drupal. It has been classified as problematic. Affected is the function basic_cart_checkout_form_submit of the file basic_cart.cart.inc. The manipulation leads to cross site scripting. It is possible to launch the attack remotely. Upgrading to version 1.x-1.1.1 is able to address this issue. The patch is identified as a10424ccd4b3b4b433cf33b73c1ad608b11890b4. It is recommended to upgrade the affected component. VDB-217950 is the identifier assigned to this vulnerability.
Affected products
- backdrop-contrib Basic Cart: before 1.x-1.1.1 — fixed in 1.x-1.1.1
How to fix
Upgrade to a fixed version: backdrop-contrib Basic Cart 1.x-1.1.1. Check the vendor advisory for mitigations.
References
- https://github.com/backdrop-contrib/basic_cart/commit/a10424ccd4b3b4b433cf33b73c1ad608b11890b4
- https://github.com/backdrop-contrib/basic_cart/releases/tag/1.x-1.1.1
- https://vuldb.com/?ctiid.217950
- https://vuldb.com/?id.217950
- https://github.com/backdrop-contrib/basic_cart/commit/a10424ccd4b3b4b433cf33b73c1ad608b11890b4
- https://github.com/backdrop-contrib/basic_cart/releases/tag/1.x-1.1.1
- https://vuldb.com/?ctiid.217950
- https://vuldb.com/?id.217950
Get alerted when CVE-2012-10004 or the next vulnerability affects your stack