What’s Vulnerable › Vulnerabilities
CVE-2012-10007: madgicweb BuddyStream Plugin ShareBox.php cross site scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-02-19 · updated 2026-06-16
- Weakness: CWE-79
Description
A vulnerability was found in madgicweb BuddyStream Plugin up to 3.2.7 on WordPress. It has been declared as problematic. Affected by this vulnerability is an unknown functionality of the file ShareBox.php. The manipulation of the argument content/link/shares leads to cross site scripting. The attack can be launched remotely. Upgrading to version 3.2.8 is able to address this issue. The patch is named 7d5b9a89a27711aad76fd55ab4cc4185b545a1d0. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-221479.
Affected products
- madgicweb BuddyStream Plugin: before 3.2.8 — fixed in 3.2.8
How to fix
Upgrade to a fixed version: madgicweb BuddyStream Plugin 3.2.8. Check the vendor advisory for mitigations.
References
- https://github.com/madgicweb/buddystream/commit/7d5b9a89a27711aad76fd55ab4cc4185b545a1d0
- https://github.com/madgicweb/buddystream/releases/tag/3.2.8
- https://vuldb.com/?ctiid.221479
- https://vuldb.com/?id.221479
- https://github.com/madgicweb/buddystream/commit/7d5b9a89a27711aad76fd55ab4cc4185b545a1d0
- https://github.com/madgicweb/buddystream/releases/tag/3.2.8
- https://vuldb.com/?ctiid.221479
- https://vuldb.com/?id.221479
Get alerted when CVE-2012-10007 or the next vulnerability affects your stack