What’s Vulnerable › Vulnerabilities
CVE-2012-10009: 404like Plugin 404Like.php checkPage sql injection
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-21 · updated 2026-06-16
- Weakness: CWE-89
Description
A vulnerability was found in 404like Plugin up to 1.0.2 on WordPress. It has been classified as critical. Affected is the function checkPage of the file 404Like.php. The manipulation of the argument searchWord leads to sql injection. It is possible to launch the attack remotely. Upgrading to version 1.0.2 is able to address this issue. The name of the patch is 2c4b589d27554910ab1fd104ddbec9331b540f7f. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-223404.
Affected products
- 404like Plugin: before 1.0.2 — fixed in 1.0.2
How to fix
Upgrade to a fixed version: 404like Plugin 1.0.2. Check the vendor advisory for mitigations.
References
- https://github.com/wp-plugins/404like/commit/2c4b589d27554910ab1fd104ddbec9331b540f7f
- https://github.com/wp-plugins/404like/releases/tag/1.0.2
- https://vuldb.com/?ctiid.223404
- https://vuldb.com/?id.223404
- https://github.com/wp-plugins/404like/commit/2c4b589d27554910ab1fd104ddbec9331b540f7f
- https://github.com/wp-plugins/404like/releases/tag/1.0.2
- https://vuldb.com/?ctiid.223404
- https://vuldb.com/?id.223404
Get alerted when CVE-2012-10009 or the next vulnerability affects your stack