What’s Vulnerable › Vulnerabilities
CVE-2012-1001
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-11-21 · updated 2026-06-16
- Weakness: CWE-79
Description
Multiple cross-site scripting (XSS) vulnerabilities in Chyrp before 2.1.2 and before 2.5 Beta 2 allow remote attackers to inject arbitrary web script or HTML via the (1) content parameter to includes/ajax.php or (2) body parameter to includes/error.php.
Affected products
- Chyrp: before 2.1.2; 2.5.2-b1 — fixed in 2.1.2
How to fix
Upgrade to a fixed version: Chyrp 2.1.2. Check the vendor advisory for mitigations.
References
- http://archives.neohapsis.com/archives/bugtraq/2012-02/0121.html
- http://chyrp.net/2012/02/02/heres-whats-been-going-on-recently/
- http://www.securityfocus.com/bid/52115
- http://www.securityfocus.com/bid/52117
- https://github.com/vito/chyrp/commit/f69bd791c37e0b154c0bda16f9759ba19cc77f6c
- https://www.htbridge.ch/advisory/HTB23073
- http://archives.neohapsis.com/archives/bugtraq/2012-02/0121.html
- http://chyrp.net/2012/02/02/heres-whats-been-going-on-recently/
- http://www.securityfocus.com/bid/52115
- http://www.securityfocus.com/bid/52117
- https://github.com/vito/chyrp/commit/f69bd791c37e0b154c0bda16f9759ba19cc77f6c
- https://www.htbridge.ch/advisory/HTB23073
Get alerted when CVE-2012-1001 or the next vulnerability affects your stack