What’s Vulnerable › Vulnerabilities
CVE-2012-10014: Kau-Boy Backend Localization Plugin backend_localization.php localize_backend cross site scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-04-24 · updated 2026-06-16
- Weakness: CWE-79
Description
A vulnerability classified as problematic has been found in Kau-Boy Backend Localization Plugin 2.0 on WordPress. Affected is the function backend_localization_admin_settings/backend_localization_save_setting/backend_localization_login_form/localize_backend of the file backend_localization.php. The manipulation leads to cross site scripting. It is possible to launch the attack remotely. Upgrading to version 2.0.1 is able to address this issue. The name of the patch is 36f457ee16dd114e510fd91a3ea9fbb3c1f87184. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-227232.
Affected products
- Kau-Boy Backend Localization Plugin: before 2.0.1 — fixed in 2.0.1
How to fix
Upgrade to a fixed version: Kau-Boy Backend Localization Plugin 2.0.1. Check the vendor advisory for mitigations.
References
- https://github.com/wp-plugins/kau-boys-backend-localization/commit/36f457ee16dd114e510fd91a3ea9fbb3c1f87184
- https://github.com/wp-plugins/kau-boys-backend-localization/releases/tag/2.0.1
- https://vuldb.com/?ctiid.227232
- https://vuldb.com/?id.227232
- https://github.com/wp-plugins/kau-boys-backend-localization/commit/36f457ee16dd114e510fd91a3ea9fbb3c1f87184
- https://github.com/wp-plugins/kau-boys-backend-localization/releases/tag/2.0.1
- https://vuldb.com/?ctiid.227232
- https://vuldb.com/?id.227232
Get alerted when CVE-2012-10014 or the next vulnerability affects your stack