What’s Vulnerable › Vulnerabilities
CVE-2012-10015: BestWebSoft Twitter Plugin Settings Page twitter.php twttr_settings_page cross-site request forgery
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-05-31 · updated 2026-06-16
- Weakness: CWE-352
Description
A vulnerability was found in BestWebSoft Twitter Plugin up to 2.14 on WordPress. It has been classified as problematic. Affected is the function twttr_settings_page of the file twitter.php of the component Settings Page. The manipulation leads to cross-site request forgery. It is possible to launch the attack remotely. Upgrading to version 2.15 is able to address this issue. The patch is identified as a6d4659cbb2cbf18ccb0fb43549d5113d74e0146. It is recommended to upgrade the affected component. VDB-230154 is the identifier assigned to this vulnerability.
Affected products
- BestWebSoft Twitter Plugin: before 2.15 — fixed in 2.15
How to fix
Upgrade to a fixed version: BestWebSoft Twitter Plugin 2.15. Check the vendor advisory for mitigations.
References
- https://github.com/wp-plugins/twitter-plugin/commit/a6d4659cbb2cbf18ccb0fb43549d5113d74e0146
- https://vuldb.com/?ctiid.230154
- https://vuldb.com/?id.230154
- https://github.com/wp-plugins/twitter-plugin/commit/a6d4659cbb2cbf18ccb0fb43549d5113d74e0146
- https://vuldb.com/?ctiid.230154
- https://vuldb.com/?id.230154
Get alerted when CVE-2012-10015 or the next vulnerability affects your stack