What’s Vulnerable › Vulnerabilities
CVE-2012-1168
- Severity: high (CVSS 8.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-11-14 · updated 2026-06-16
- Weakness: CWE-20
Description
Moodle before 2.2.2 has a password and web services issue where when the user profile is updated the user password is reset if not specified.
Affected products
- Fedoraproject Fedora: 15, 16, 17
- Moodle: before 2.2.2 — fixed in 2.2.2
- Red Hat Enterprise Linux: 6.0
How to fix
Upgrade to a fixed version: Moodle 2.2.2. Check the vendor advisory for mitigations.
References
- http://lists.fedoraproject.org/pipermail/package-announce/2012-April/077635.html
- http://lists.fedoraproject.org/pipermail/package-announce/2012-April/078209.html
- http://lists.fedoraproject.org/pipermail/package-announce/2012-April/078210.html
- http://lists.fedoraproject.org/pipermail/package-announce/2012-May/080712.html
- http://lists.fedoraproject.org/pipermail/package-announce/2012-May/081047.html
- https://access.redhat.com/security/cve/cve-2012-1168
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2012-1168
- https://moodle.org/mod/forum/discuss.php?d=198622
- https://security-tracker.debian.org/tracker/CVE-2012-1168
- http://lists.fedoraproject.org/pipermail/package-announce/2012-April/077635.html
- http://lists.fedoraproject.org/pipermail/package-announce/2012-April/078209.html
- http://lists.fedoraproject.org/pipermail/package-announce/2012-April/078210.html
Get alerted when CVE-2012-1168 or the next vulnerability affects your stack