What’s Vulnerable › Vulnerabilities
CVE-2012-1170
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-11-14 · updated 2026-06-16
- Weakness: CWE-354
Description
Moodle before 2.2.2 has an external enrolment plugin context check issue where capability checks are not thorough
Affected products
- Fedoraproject Fedora: 15, 16, 17
- Moodle: before 2.2.2 — fixed in 2.2.2
How to fix
Upgrade to a fixed version: Moodle 2.2.2. Check the vendor advisory for mitigations.
References
- http://lists.fedoraproject.org/pipermail/package-announce/2012-April/077635.html
- http://lists.fedoraproject.org/pipermail/package-announce/2012-April/078209.html
- http://lists.fedoraproject.org/pipermail/package-announce/2012-April/078210.html
- http://lists.fedoraproject.org/pipermail/package-announce/2012-May/080712.html
- http://lists.fedoraproject.org/pipermail/package-announce/2012-May/081047.html
- https://access.redhat.com/security/cve/cve-2012-1170
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2012-1170
- https://moodle.org/mod/forum/discuss.php?d=198632
- https://security-tracker.debian.org/tracker/CVE-2012-1170
- http://lists.fedoraproject.org/pipermail/package-announce/2012-April/077635.html
- http://lists.fedoraproject.org/pipermail/package-announce/2012-April/078209.html
- http://lists.fedoraproject.org/pipermail/package-announce/2012-April/078210.html
Get alerted when CVE-2012-1170 or the next vulnerability affects your stack