What’s Vulnerable › Vulnerabilities

CVE-2012-1180

Description

Use-after-free vulnerability in nginx before 1.0.14 and 1.1.x before 1.1.17 allows remote HTTP servers to obtain sensitive information from process memory via a crafted backend response, in conjunction with a client request.

Affected products

How to fix

Upgrade to a fixed version: nginx 1.0.14, 1.1.17. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2012-1180 or the next vulnerability affects your stack