What’s Vulnerable › Vulnerabilities
CVE-2012-1495
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 79.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-01-27 · updated 2026-06-16
- Weakness: CWE-74
Description
install/index.php in WebCalendar before 1.2.5 allows remote attackers to execute arbitrary code via the form_single_user_login parameter.
Affected products
- k5n.us WebCalendar: before 1.2.5 — fixed in 1.2.5
How to fix
Upgrade to a fixed version: k5n.us WebCalendar 1.2.5. Check the vendor advisory for mitigations.
References
- http://sourceforge.net/projects/webcalendar/files/webcalendar%201.2/1.2.5/
- https://packetstormsecurity.com/files/112323/WebCalendar-1.2.4-Pre-Auth-Remote-Code-Injection.html
- https://packetstormsecurity.com/files/112332/WebCalendar-1.2.4-Remote-Code-Execution.html
- https://www.exploit-db.com/exploits/18775
- http://sourceforge.net/projects/webcalendar/files/webcalendar%201.2/1.2.5/
- https://packetstormsecurity.com/files/112323/WebCalendar-1.2.4-Pre-Auth-Remote-Code-Injection.html
- https://packetstormsecurity.com/files/112332/WebCalendar-1.2.4-Remote-Code-Execution.html
- https://www.exploit-db.com/exploits/18775
Get alerted when CVE-2012-1495 or the next vulnerability affects your stack