What’s Vulnerable › Vulnerabilities
CVE-2012-1535: Adobe Flash Player Arbitrary Code Execution Vulnerability
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2022-03-03
- EPSS: 70.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2012-08-15 · updated 2026-06-16
- Weakness: CWE-20
Description
Unspecified vulnerability in Adobe Flash Player before 11.3.300.271 on Windows and Mac OS X and before 11.2.202.238 on Linux allows remote attackers to execute arbitrary code or cause a denial of service (application crash) via crafted SWF content, as exploited in the wild in August 2012 with SWF content in a Word document.
Affected products
- Adobe Flash Player 24.0.0.186 and earlier.: before 11.3.300.271; before 11.2.202.238 — fixed in 11.2.202.238, 11.3.300.271
- Opensuse: 11.4, 12.1
- RedHat Enterprise Linux Desktop: 5.0
- RedHat Enterprise Linux Server: 5.0
- RedHat Enterprise Linux Workstation: 5.0
- SUSE Linux Enterprise Server 15 SP1: 10-sp4
How to fix
Upgrade to a fixed version: Adobe Flash Player 24.0.0.186 and earlier. 11.2.202.238, 11.3.300.271. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2012-08/msg00010.html
- http://lists.opensuse.org/opensuse-security-announce/2012-08/msg00012.html
- http://marc.info/?l=bugtraq&m=139455789818399&w=2
- http://rhn.redhat.com/errata/RHSA-2012-1203.html
- http://security.gentoo.org/glsa/glsa-201209-01.xml
- http://www.adobe.com/support/security/bulletins/apsb12-18.html
- http://lists.opensuse.org/opensuse-security-announce/2012-08/msg00010.html
- http://lists.opensuse.org/opensuse-security-announce/2012-08/msg00012.html
- http://marc.info/?l=bugtraq&m=139455789818399&w=2
- http://rhn.redhat.com/errata/RHSA-2012-1203.html
- http://security.gentoo.org/glsa/glsa-201209-01.xml
- http://www.adobe.com/support/security/bulletins/apsb12-18.html
Get alerted when CVE-2012-1535 or the next vulnerability affects your stack