What’s Vulnerable › Vulnerabilities
CVE-2012-1610
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2012-06-05 · updated 2026-06-16
- Weakness: CWE-190
Description
Integer overflow in the GetEXIFProperty function in magick/property.c in ImageMagick before 6.7.6-4 allows remote attackers to cause a denial of service (out-of-bounds read) via a large component count for certain EXIF tags in a JPEG image. NOTE: this vulnerability exists because of an incomplete fix for CVE-2012-0259.
Affected products
- Canonical Ubuntu Linux: 10.04, 11.04, 11.10, 12.04
- Debian Linux: 6.0
- ImageMagick: before 6.7.6-4 — fixed in 6.7.6-4
- Opensuse: 11.4, 12.1
How to fix
Upgrade to a fixed version: ImageMagick 6.7.6-4. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-updates/2012-06/msg00001.html
- http://secunia.com/advisories/48974
- http://secunia.com/advisories/49043
- http://secunia.com/advisories/49317
- http://secunia.com/advisories/55035
- http://ubuntu.com/usn/usn-1435-1
- http://www.debian.org/security/2012/dsa-2462
- http://www.imagemagick.org/discourse-server/viewtopic.php?f=4&t=20629
- http://www.openwall.com/lists/oss-security/2012/04/04/6
- http://www.osvdb.org/81024
- http://www.securityfocus.com/bid/52898
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2012-0259
Get alerted when CVE-2012-1610 or the next vulnerability affects your stack