What’s Vulnerable › Vulnerabilities

CVE-2012-1823: PHP-CGI Query String Parameter Vulnerability

Description

sapi/cgi/cgi_main.c in PHP before 5.3.12 and 5.4.x before 5.4.2, when configured as a CGI script (aka php-cgi), does not properly handle query strings that lack an = (equals sign) character, which allows remote attackers to execute arbitrary code by placing command-line options in the query string, related to lack of skipping a certain php_getopt for the 'd' case.

Affected products

How to fix

Upgrade to a fixed version: macOS 10.7.5, 10.8.2; PHP 5.3.12, 5.4.2. Check the vendor advisory for mitigations.

In the news

References

Get alerted when CVE-2012-1823 or the next vulnerability affects your stack