What’s Vulnerable › Vulnerabilities
CVE-2012-1915
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-01-09 · updated 2026-06-16
- Weakness: CWE-79
Description
EllisLab CodeIgniter 2.1.2 allows remote attackers to bypass the xss_clean() Filter and perform XSS attacks.
Affected products
- CodeIgniter4: before 2.1.2 — fixed in 2.1.2
How to fix
Upgrade to a fixed version: CodeIgniter4 2.1.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2012-1915 or the next vulnerability affects your stack