What’s Vulnerable › Vulnerabilities
CVE-2012-1987
- Severity: low (CVSS 3.5 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2012-05-29 · updated 2026-06-16
Description
Unspecified vulnerability in Puppet 2.6.x before 2.6.15 and 2.7.x before 2.7.13, and Puppet Enterprise (PE) Users 1.0, 1.1, 1.2.x, 2.0.x, and 2.5.x before 2.5.1 allows remote authenticated users with agent SSL keys to (1) cause a denial of service (memory consumption) via a REST request to a stream that triggers a thread block, as demonstrated using CVE-2012-1986 and /dev/random; or (2) cause a denial of service (filesystem consumption) via crafted REST requests that use "a marshaled form of a Puppet::FileBucket::File object" to write to arbitrary file locations.
Affected products
- Puppet Agent: from 2.6.0 before 2.6.15; from 2.7.0 before 2.7.13 — fixed in 2.6.15, 2.7.13
- Puppet Enterprise: from 1.0 before 2.5.1 — fixed in 2.5.1
How to fix
Upgrade to a fixed version: Puppet Agent 2.6.15, 2.7.13; Puppet Enterprise 2.5.1. Check the vendor advisory for mitigations.
References
- http://lists.fedoraproject.org/pipermail/package-announce/2012-April/079227.html
- http://lists.fedoraproject.org/pipermail/package-announce/2012-April/079289.html
- http://lists.fedoraproject.org/pipermail/package-announce/2012-May/080003.html
- http://projects.puppetlabs.com/issues/13552
- http://projects.puppetlabs.com/issues/13553
- http://projects.puppetlabs.com/projects/1/wiki/Release_Notes#2.6.15
- http://puppetlabs.com/security/cve/cve-2012-1987/
- http://puppetlabs.com/security/cve/cve-2012-1987/hotfixes/
- http://secunia.com/advisories/48743
- http://secunia.com/advisories/48748
- http://secunia.com/advisories/48789
- http://secunia.com/advisories/49136
Get alerted when CVE-2012-1987 or the next vulnerability affects your stack