What’s Vulnerable › Vulnerabilities
CVE-2012-20001
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-12-21 · updated 2026-06-16
- Weakness: CWE-79
Description
PrestaShop before 1.5.2 allows XSS via the "<object data='data:text/html" substring in the message field.
Affected products
- PrestaShop: before 1.5.2 — fixed in 1.5.2
How to fix
Upgrade to a fixed version: PrestaShop 1.5.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2012-20001 or the next vulnerability affects your stack