What’s Vulnerable › Vulnerabilities
CVE-2012-20002: TinyMCE Thumbnail Gallery WordPress Plugin < 1.1.0 Path Traversal via download-image.php
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-20 · updated 2026-10-23
- Weakness: CWE-22
Description
TinyMCE Thumbnail Gallery plugin for WordPress before 1.1.0 contains a path traversal vulnerability that allows unauthenticated attackers to read arbitrary files via the href parameter. Attackers can send GET requests to /php/download-image.php with traversal sequences like ../../../../wp-config.php to retrieve database credentials and system files. Exploitation evidence was first observed by the Shadowserver Foundation on 2023-10-19.
Affected products
- James Charlesworth TinyMCE Thumbnail Gallery: from 0.10 before 1.1.0 — fixed in 1.1.0
How to fix
Upgrade to a fixed version: James Charlesworth TinyMCE Thumbnail Gallery 1.1.0. Check the vendor advisory for mitigations.
References
- https://github.com/projectdiscovery/nuclei-templates/blob/main/http/vulnerabilities/wordpress/wp-tinymce-lfi.yaml
- https://packetstorm.news/files/id/113417/
- https://wordpress.org/plugins/tinymce-thumbnail-gallery/
- https://wpscan.com/vulnerability/4a49b023-c1c9-4cc4-a2fd-af5f911bb400
- https://www.exploit-db.com/exploits/19022
- https://www.vulncheck.com/advisories/tinymce-thumbnail-gallery-wordpress-plugin-1.1.0-path-traversal-via-download-image-php
Get alerted when CVE-2012-20002 or the next vulnerability affects your stack