What’s Vulnerable › Vulnerabilities
CVE-2012-20003: Custom Tables WordPress Plugin < 3.4.6 Reflected XSS via iframe.php
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-20 · updated 2026-10-23
- Weakness: CWE-79
Description
Custom Tables plugin for WordPress before 3.4.6 contains a reflected cross-site scripting vulnerability that allows unauthenticated attackers to inject scripts through the unsanitized 'key' parameter in iframe.php. Attackers can craft GET requests to /wp-content/plugins/custom-tables/iframe.php with s=1 and a malicious key value to execute script in victims' browsers and steal cookies. Exploitation evidence was first observed by the Shadowserver Foundation on 2023-10-20.
Affected products
- Web Updates KMU Custom Tables: before 3.4.6 — fixed in 3.4.6
How to fix
Upgrade to a fixed version: Web Updates KMU Custom Tables 3.4.6. Check the vendor advisory for mitigations.
References
- https://github.com/projectdiscovery/nuclei-templates/blob/main/http/vulnerabilities/wordpress/wp-custom-tables-xss.yaml
- https://wordpress.org/plugins/custom-tables/
- https://wpscan.com/vulnerability/211a4286-4747-4b62-acc3-fd9a57b06252
- https://www.acunetix.com/vulnerabilities/web/wordpress-plugin-custom-tables-key-parameter-cross-site-scripting-3-4-4/
- https://www.exploit-db.com/exploits/37482
- https://www.vulncheck.com/advisories/custom-tables-wordpress-plugin-3.4.6-reflected-xss-via-iframe-php
Get alerted when CVE-2012-20003 or the next vulnerability affects your stack