What’s Vulnerable › Vulnerabilities
CVE-2012-20004: K-news WordPress Plugin < 1.1.1 Reflected XSS via fontpicker index.php ff Parameter
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-20 · updated 2026-10-23
- Weakness: CWE-79
Description
K-news plugin for WordPress before 1.1.1 contains a reflected cross-site scripting vulnerability that allows unauthenticated attackers to inject script by supplying unsanitized input through the 'ff' parameter. Attackers can craft GET requests to /wp-content/plugins/knews/wysiwyg/fontpicker/index.php with malicious 'ff' values echoed into option tags to execute script and steal session cookies. Exploitation evidence was first observed by the Shadowserver Foundation on 2023-10-19.
Affected products
- Carles Reverter K-news: before 1.1.1 — fixed in 1.1.1
How to fix
Upgrade to a fixed version: Carles Reverter K-news 1.1.1. Check the vendor advisory for mitigations.
References
- http://web.archive.org/web/20210213220043/https://www.securityfocus.com/bid/54330/info
- https://github.com/projectdiscovery/nuclei-templates/blob/main/http/vulnerabilities/wordpress/wp-knews-xss.yaml
- https://wordpress.org/plugins/knews/
- https://www.acunetix.com/vulnerabilities/web/wordpress-plugin-knews-multilingual-newsletters-ff-parameter-cross-site-scripting-1-1-0
- https://www.exploit-db.com/exploits/37484
- https://www.vulncheck.com/advisories/k-news-wordpress-plugin-1.1.1-reflected-xss-via-fontpicker-index-php-ff-parameter
Get alerted when CVE-2012-20004 or the next vulnerability affects your stack