What’s Vulnerable › Vulnerabilities

CVE-2012-2123

Description

The cap_bprm_set_creds function in security/commoncap.c in the Linux kernel before 3.3.3 does not properly handle the use of file system capabilities (aka fcaps) for implementing a privileged executable file, which allows local users to bypass intended personality restrictions via a crafted application, as demonstrated by an attack that uses a parent process to disable ASLR.

Affected products

How to fix

Upgrade to a fixed version: Linux kernel 3.0.29, 3.2.16, 3.3.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2012-2123 or the next vulnerability affects your stack