What’s Vulnerable › Vulnerabilities
CVE-2012-2135
- Severity: medium (CVSS 6.4 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2012-08-14 · updated 2026-06-16
Description
The utf-16 decoder in Python 3.1 through 3.3 does not update the aligned_end variable after calling the unicode_decode_call_errorhandler function, which allows remote attackers to obtain sensitive information (process memory) or cause a denial of service (memory corruption and crash) via unspecified vectors.
Affected products
- Canonical Ubuntu Linux: 10.04, 11.04, 11.10, 12.04, 12.10
- Debian Linux: 6.0
- Python: from 2.7.0 before 2.7.4; from 3.2.0 before 3.2.4; from 3.3.0 before 3.3.3 — fixed in 2.7.4, 3.2.4, 3.3.3
How to fix
Upgrade to a fixed version: Python 2.7.4, 3.2.4, 3.3.3. Check the vendor advisory for mitigations.
References
- http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=670389
- http://bugs.python.org/issue14579
- http://secunia.com/advisories/51087
- http://secunia.com/advisories/51089
- http://www.openwall.com/lists/oss-security/2012/04/25/2
- http://www.openwall.com/lists/oss-security/2012/04/25/4
- http://www.ubuntu.com/usn/USN-1615-1
- http://www.ubuntu.com/usn/USN-1616-1
- http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=670389
- http://bugs.python.org/issue14579
- http://secunia.com/advisories/51087
- http://secunia.com/advisories/51089
Get alerted when CVE-2012-2135 or the next vulnerability affects your stack