What’s Vulnerable › Vulnerabilities

CVE-2012-2136

Description

The sock_alloc_send_pskb function in net/core/sock.c in the Linux kernel before 3.4.5 does not properly validate a certain length value, which allows local users to cause a denial of service (heap-based buffer overflow and system crash) or possibly gain privileges by leveraging access to a TUN/TAP device.

Affected products

How to fix

Upgrade to a fixed version: Linux kernel 3.0.37, 3.2.23, 3.4.5. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2012-2136 or the next vulnerability affects your stack